Geeks With Blogs
Michael Van Cleave Traveling the technical world, learning the language

Okay, I must be missing something.  I have been reading Visual C# 2005: A Developer's Notebook by JesseLibery and decided that I wanted to code out the example that he had for the new Forms Authentication stuff. 

I tried to download Sql 2005 Express (just becuse I am lazy and don't want to put another huge tool on my box that might not get used anytime soon), and when I tried to install it, it said that I had some other files that would keep it from installing correctly.  So, I go back to MSDN, and read a little bit and find this statement:

Step 2: Use Add/Remove Programs to remove Microsoft .NET Framework versions 1.2 or 2.0, if installed.

Note: You do not have to uninstall Microsoft .NET Framework Versions 1.0 and 1.1.

Okay, so I am using VS2005 so that automatically makes me think that from what this is saying is to uninstall the .NET framework 2.0.  Yeah...  I don't think so.  I am sure that since the new framework is shipped with SQL now that it is just trying to be sure that it has the correct version installed, but it makes me wonder about the compatabilility between these tools.. 

Is ther some sort of INSTALLATION ORDER?  If so, I would expect SQL Express to be installed after the development environment.

Either way, Check out Jesse's book.  I like it a lot.  He gets right to the meat of the new changes that are coming in the next version of VS2005. 

Until the next buffer overflow.

Michael

Posted on Sunday, August 21, 2005 5:59 PM | Back to top


Comments on this post: SQL 2005 Express, I must have missed something...

# re: SQL 2005 Express, I must have missed something...
Requesting Gravatar...
I am using both .Net Framework 1.1 and 2.0 on my machine since Beta2 release of 2.0

I did not face any problems with non ASP.Net applications, and for ASP.Net applications, you need to use the aspnet_regiis tool to correctly specify the version of ASP.Net to use.
Left by IamJunk on Aug 21, 2005 11:02 PM

# re: SQL 2005 Express, I must have missed something...
Requesting Gravatar...
On the machine I was on, it only has the 2.0 framework installed, but it would not continue the installation of SQL Express until I uninstall the 2.0 framework.

I was actually trying to get to the of running the script for forms based authentication sql setup (aspnet_regsql) so that I could setup users and roles.

I will read a little more about express and see if there is something else that is hampering my install, but that seem like the only thing (since this is a very clean box currently).

Michael
Left by Michael on Aug 22, 2005 3:04 AM

Your comment:
 (will show your gravatar)


Copyright © Michael Van Cleave | Powered by: GeeksWithBlogs.net